Multiple Static IP not working

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
omicron26
DD-WRT Novice


Joined: 30 Dec 2011
Posts: 8

PostPosted: Mon Jan 02, 2012 9:57    Post subject: Multiple Static IP not working Reply with quote
Linksys E3000 with DD-WRT v24-sp2 (04/13/11) std-usb-nas (SVN revision 16785)

I have 2 static IPs that I want to forward to 2 computers, 1 each. I've assigned local static IPs on the computers.

I was able to forward Port 80 by creating an entry at NAT/QoS page, Port Forwarding. I also had to setup the Firewall Script to do this.

I installed a script to forward Port 80 for the second IP but whenever I browse the IP, it only gives me the DD-WRT router page. Below is the script ran at startup. xxx.xxx.xxx.xxx is the public static IP.


/usr/sbin/ip addr add xxx.xxx.xxx.xxx/29 dev vlan1

/usr/sbin/iptables -t nat -I POSTROUTING 1 -p all -s 192.168.1.210 -j SNAT --to xxx.xxx.xxx.xxx

/usr/sbin/iptables -t nat -A PREROUTING -p tcp -d xxx.xxx.xxx.xxx --dport 3389 -j DNAT --to-destination 192.168.1.210:3389
/usr/sbin/iptables -I FORWARD -p tcp -d 192.168.1.210 --dport 80 -j ACCEPT


Please help. I don't know what I'm missing. Thanks.
Sponsor
omicron26
DD-WRT Novice


Joined: 30 Dec 2011
Posts: 8

PostPosted: Wed Jan 11, 2012 7:55    Post subject: Reply with quote
i haven't receive help regarding this problem. i would appreciate any information or help. thanks.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum