DNSMasq server-option stopped working ?!

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
cyberde
DD-WRT Guru


Joined: 07 Jun 2006
Posts: 1488
Location: the Netherlands

PostPosted: Sun Aug 15, 2010 10:13    Post subject: DNSMasq server-option stopped working ?! Reply with quote
Hi all,

I've just flashed my WRT320N to the latest build available (using the router database) and I'm noticing that my DNSMasq config partially has stopped working.
I'm using this config:
Code:
root@WRT_CYBERDE:~# cat /tmp/dnsmasq.conf
listen-address=127.0.0.1,192.168.0.1
resolv-file=/tmp/resolv.dnsmasq
domain=cyberde.nl
dhcp-leasefile=/tmp/dnsmasq.leases
dhcp-lease-max=53
dhcp-option=lan,3,192.168.0.1
dhcp-authoritative
dhcp-range=lan,192.168.0.100,192.168.0.149,255.255.254.0,480m
stop-dns-rebind
address=/www.cyberde.nl/193.33.61.36
server=/cyberde.nl/172.16.1.100
server=/droppert.local/192.168.1.1
dhcp-option=42,nl.pool.ntp.org

I also have a domain controller in my network for the cyberde.nl domain, using the server-option I was able to route every request made for *.cyberde.nl to 172.16.1.100.

So if one of my clients made a request for let's say dc.cyberde.nl to 192.168.0.1 (my router) it would forward this request to 172.16.1.100. Resulting a lookup on my domain controller.

However this has stopped working since I flashed 08/07/10 (SVN revision: 14896).

Does anyone else has this issue?

_________________
Firmware: DD-WRT v24-sp2 (latest available) mega
WRT320N

Donater
Sponsor
Skydiver
DD-WRT User


Joined: 23 Feb 2009
Posts: 298
Location: Germany

PostPosted: Sun Aug 15, 2010 18:40    Post subject: Reply with quote
hi,
the "stop dns rebind" parameter is new in the dnsmasq config.

It`s changed in 14838.

http://svn.dd-wrt.com:8000/dd-wrt/changeset/14838

If this has something to do with your problem, go back to a build behind 14838 and test...

_________________
Netgear WNR834B v2 - Eko build v24-sp2 15943M mini NEWD K2.4 (running MINIUPNPD)
Tested with BS 15943 mini build with my 32/1 line over wireless:
cyberde
DD-WRT Guru


Joined: 07 Jun 2006
Posts: 1488
Location: the Netherlands

PostPosted: Mon Aug 16, 2010 6:47    Post subject: Reply with quote
Hi,

I noticed that option too, so I killed dnsmasq, removed that option from the config file and restarted dnsmasq (using dnsmasq --conf-file=/tmp/dnsmasq.conf).

After that I tried pinging a .cyberde.nl server in my network but it still won't resolve. So I'm guessing that's not causing the problem.

The only thing I've changed after flashing is enabling PPTP Server. Will try to disable that and recheck.

_________________
Firmware: DD-WRT v24-sp2 (latest available) mega
WRT320N

Donater
cyberde
DD-WRT Guru


Joined: 07 Jun 2006
Posts: 1488
Location: the Netherlands

PostPosted: Mon Aug 16, 2010 6:49    Post subject: Reply with quote
Okay, disabled PPTP Server but no joy. It's something else... Sad
_________________
Firmware: DD-WRT v24-sp2 (latest available) mega
WRT320N

Donater
cyberde
DD-WRT Guru


Joined: 07 Jun 2006
Posts: 1488
Location: the Netherlands

PostPosted: Tue Aug 17, 2010 19:57    Post subject: Reply with quote
Bumbty bumb...
_________________
Firmware: DD-WRT v24-sp2 (latest available) mega
WRT320N

Donater
cyberde
DD-WRT Guru


Joined: 07 Jun 2006
Posts: 1488
Location: the Netherlands

PostPosted: Tue Aug 24, 2010 8:25    Post subject: Reply with quote
Bump.

Still not working in the latest BS release Sad

_________________
Firmware: DD-WRT v24-sp2 (latest available) mega
WRT320N

Donater
launila
DD-WRT Novice


Joined: 18 Jul 2010
Posts: 9

PostPosted: Wed Sep 01, 2010 13:12    Post subject: Re: DNSMasq server-option stopped working ?! Reply with quote
cyberde wrote:

I've jus flashed my WRT320N to the latest build available (using the router database) and I'm noticing that my DNSMasq config partially has stopped working.


Hello

I upgraded my WRT-G300N to build 14896 and noticed same problem that server-parameter has not any effect now. I used that option to get dns queries working via OpenVPN tunnel between my two lans.

Have you solved your problem?

edit: For me removing stop-dns-rebind helped problem. New dnsmasq versions has an option rebind-domain-ok=/your.sec.domain.com/ which would help us here.

Could somebody add an option to dd-wrt webinterface for stop-dns-rebind? Or could somebody update dd-wrt dnsmasq to newest version?
cyberde
DD-WRT Guru


Joined: 07 Jun 2006
Posts: 1488
Location: the Netherlands

PostPosted: Wed Sep 01, 2010 14:20    Post subject: Re: DNSMasq server-option stopped working ?! Reply with quote
launila wrote:
Have you solved your problem?

No I havn't yet. Although it seemed that removing the stop-dns-rebind didn't have any effect.

Does the rebind-domain-ok=/your.sec.domain.com/ work?

_________________
Firmware: DD-WRT v24-sp2 (latest available) mega
WRT320N

Donater
launila
DD-WRT Novice


Joined: 18 Jul 2010
Posts: 9

PostPosted: Wed Sep 01, 2010 14:38    Post subject: Re: DNSMasq server-option stopped working ?! Reply with quote
cyberde wrote:
launila wrote:
Have you solved your problem?

No I havn't yet. Although it seemed that removing the stop-dns-rebind didn't have any effect.

Does the rebind-domain-ok=/your.sec.domain.com/ work?


DD-WRT does not have enough new dnsmasq for that option. I created ticket for dnsmasq upgrading request.

It seems that somebody had opened ticket about that stop-dns-rebind-problem. So I think we will see configuration option for this when next build is released.
cyberde
DD-WRT Guru


Joined: 07 Jun 2006
Posts: 1488
Location: the Netherlands

PostPosted: Wed Sep 01, 2010 15:17    Post subject: Reply with quote
Okay awesome Smile I sure hope that will be an option cause it's annoying me as hell and I do not want to downgrade Razz
_________________
Firmware: DD-WRT v24-sp2 (latest available) mega
WRT320N

Donater
cyberde
DD-WRT Guru


Joined: 07 Jun 2006
Posts: 1488
Location: the Netherlands

PostPosted: Fri Sep 03, 2010 6:57    Post subject: Reply with quote
again, bump
_________________
Firmware: DD-WRT v24-sp2 (latest available) mega
WRT320N

Donater
launila
DD-WRT Novice


Joined: 18 Jul 2010
Posts: 9

PostPosted: Thu Oct 07, 2010 17:50    Post subject: Local DNS forward Reply with quote
cyberde wrote:
Okay awesome Smile I sure hope that will be an option cause it's annoying me as hell and I do not want to downgrade Razz


Hello

I updated today firmware on one of my Buffalo WHR-G300N to release 15362. Now there is option for disabling that new default which caused problems with many local DNS servers.

I hope that there is also binary for your router. There was not binary for WRT54GL but that is my testing environment so it is not necessary to update.

Best Regards
cyberde
DD-WRT Guru


Joined: 07 Jun 2006
Posts: 1488
Location: the Netherlands

PostPosted: Tue Oct 12, 2010 13:43    Post subject: Reply with quote
Thnx mate, just got back from vacation and will check it out! :)

Update
Yeap, disabling dns-rebind fixed the problem! Very Happy

_________________
Firmware: DD-WRT v24-sp2 (latest available) mega
WRT320N

Donater
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum